400-893-5552

详解DHCP服务器中继之间跨越 GRE 隧道动态分配I

 
2020-12-30 10:35所属分类动态ip分配(5)

要求:某企业的总部和分支机构部署在不同的区域,为了使企业总部和分支机构能够互联,总部与分支机构之间部署了GRE隧道。为了方便统一管理,企业管理员在总部设备SW1上部署DHCP服务器,在SW3上部署DHCP中继,为总部和分支机构的终端分配IP地址,总部和分支机构规划的IP地址网段分别为192.168.10.0/24和192.168.40.0/24。

 

一、本节主要知识点:

1、DHCP中继用于在DHCP服务器和客户端之间转发DHCP报文。当DHCP服务器与客户端不在同一个网段时,需要配置DHCP中继。对于DHCP客户端来说,DHCP中继就是DHCP服务器;对于DHCP服务器来说,DHCP中继就是DHCP客户端。

DHCP中继适用于用户网关设备众多且分布零散的大型网络。为减少维护工作量,网络管理员不想在每个汇聚层交换机(用户网关)上都配置DHCP服务器功能,而希望在核心层设备上配置DHCP服务器功能或在服务器区域部署一台专门的DHCP服务器。此时,作为用户网关的汇聚层交换机上就需要配置DHCP中继功能,实现DHCP服务器与客户端之间的DHCP报文交互。 DHCP中继与DHCP服务器之间可以跨越VPN网络,如GRE、BGP/MPLS IP VPN等。

2、GRE隧道:GRE采用了Tunnel(隧道)技术,是VPN(Virtual Private Network)的第三层隧道协议。Tunnel 是一个虚拟的点对点的连接,提供了一条通路使封装的数据报文能够在这个通路上传输,并且在一个Tunnel 的两端分别对数据报进行封装及解封装。GRE隧道是通过隧道两端的Tunnel接口建立的,所以需要在隧道两端的设备上分别配置Tunnel接口。对于GRE的Tunnel接口,需要指定其协议类型为GRE、源地址或源接口、目的地址和Tunnel接口IP地址。

二、配置思路:

1、将各交换机的二层配通。

2、配置交换机的三层。

3、配置OSPF协议,使得全网通。

4、在SW1交换机与SW2交换机之间建立GRE隧道。

5、在SW1上建立DHCP服务器。

6、在SW2上建立DHCP中继。

三、IP设置:

SW1:VLANif10:192.168.10.254/24 ,vlan10 ,ospf, area 0

SW1:VLANif20:192.168.20.1/24 ,vlan 20 ,ospf, area 0

SW2:VLANif20:192.168.20.2/24 ,vlan 20 ,ospf, area 0

SW2:VLANif30:192.168.30.1/24 ,vlan 30 ,ospf, area 0

SW3:VLANif30:192.168.30.2/24 ,vlan 30 ,ospf, area 0

SW3:VLANif40:192.168.40.254/24 ,vlan 40 ,ospf, area 0

SW1:Tunnel1:10.1.1.1/24

SW2:Tunnel1:10.1.1.2/24

四、实操视频:

五、SW1交换机的主要配置文件:

#

sysname SW1

#

vlan batch 10 20

dhcp enable

#

ip pool pool1

gateway-list 192.168.10.254

network 192.168.10.0 mask 255.255.255.0

dns-list 61.128.114.166

#

ip pool pool2

gateway-list 192.168.40.254

network 192.168.40.0 mask 255.255.255.0

dns-list 61.128.114.166

#

interface Vlanif10

ip address 192.168.10.254 255.255.255.0

dhcp select global

#

interface Vlanif20

ip address 192.168.20.1 255.255.255.0

#

interface MEth0/0/1

#

interface GigabitEthernet0/0/1

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

interface Tunnel1

ip address 10.1.1.1 255.255.255.0

tunnel-protocol gre

source 192.168.10.254

destination 192.168.40.254

#

ospf 1 router-id 1.1.1.1

area 0.0.0.0

network 192.168.10.0 0.0.0.255

network 192.168.20.0 0.0.0.255

#

ip route-static 192.168.40.0 255.255.255.0 Tunnel1

#

return

六、SW2交换机的主要配置文件:

#

sysname SW2

#

vlan batch 20 30

#

interface Vlanif20

ip address 192.168.20.2 255.255.255.0

#

interface Vlanif30

ip address 192.168.30.1 255.255.255.0

#

interface MEth0/0/1

#

interface GigabitEthernet0/0/1

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

ospf 1 router-id 2.2.2.2

area 0.0.0.0

network 192.168.20.0 0.0.0.255

network 192.168.30.0 0.0.0.255

#

return

七、SW3交换机的主要配置文件:

#

sysname SW3

#

vlan batch 30 40

#

dhcp enable

#

interface Vlanif30

ip address 192.168.30.2 255.255.255.0

#

interface Vlanif40

ip address 192.168.40.254 255.255.255.0

dhcp select relay

dhcp relay server-ip 192.168.10.254

#

interface GigabitEthernet0/0/1

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

interface Tunnel1

ip address 10.1.1.2 255.255.255.0

tunnel-protocol gre

source 192.168.40.254

destination 192.168.10.254

#

ospf 1 router-id 3.3.3.3

area 0.0.0.0

network 192.168.30.0 0.0.0.255

network 192.168.40.0 0.0.0.255

#

ip route-static 192.168.10.0 255.255.255.0 Tunnel1

#

return

八、验证配置结果:

在总部PC1和分支PC3上自动获取IP地址,用ipconfig查看动态获取的IP地址。

 

友情链接    PPTP 代理IP 极速加速 91IP代理 IP代理 51IP代理 代理IP